Delays in incoming and outgoing SMS
Incident Report for OpenPhone
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 18:54 UTC
Update
We are continuing to investigate this issue.
Posted Jul 14, 2023 - 18:20 UTC
Update
We are continuing to investigate this issue.
Posted Jul 14, 2023 - 18:19 UTC
Investigating
We've received reports of an issue where some users are experiencing SMS delays on their OpenPhone number. We're investigating the issue now and will provide updates as soon as possible.
Posted Jul 14, 2023 - 17:47 UTC
This incident affected: IOS App, Android App, Web App, Text Messaging, Mac App, and Windows App.