Issues with making or receiving calls on all OpenPhone Apps
Incident Report for OpenPhone
Resolved
We've identified this issue and implemented a fix. We've just tested this out and received feedback that all systems are 100% operational. Thank you for your patience with us. You should be good to go!
Posted May 12, 2022 - 19:44 UTC
Investigating
Hi folks, we've received reports of an issue where some users are unable to make or receive calls on their OpenPhone number. We're investigating the issue now and should have this resolved shortly. We'll let you know as soon as we know of anything.
Posted May 12, 2022 - 19:39 UTC
This incident affected: IOS App, Android App, Web App, Mac App, and Windows App.