The issue has been resolved and the ability to purchase new numbers has been restored. If you were trying to sign up for the service, you may continue with the process now.
Thank you for your continued patience!
Posted May 03, 2023 - 02:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 02, 2023 - 22:55 UTC
Update
We are continuing to investigate this issue.
Posted May 02, 2023 - 22:51 UTC
Investigating
Hey folks, we're investigating an issue with a third-party phone number provider. While this is affecting the ability of new and existing users to purchase new phone numbers, it does not affect any functionality of OpenPhone for existing users. This will also prevent new users from signing-up. We've identified the cause of this issue and should have it resolved with this third-party provider shortly. Thank you for your patience!
Posted May 02, 2023 - 22:42 UTC
This incident affected: IOS App, Android App, Web App, Mac App, and Windows App.