Service interruption
Incident Report for OpenPhone
Resolved
The issue has been fixed and all services are operational now. Pleaser refresh your apps or log back in to regain access and start using the service.

Thank you for your patience!
Posted Mar 23, 2023 - 16:39 UTC
Investigating
Our engineers are currently investigating a system-wide outage affecting all our services. This is of the highest priority and the team is all hands on deck working on a resolution for you. We apologize for the trouble caused.

Please stay tuned as we provide updates on this.
Posted Mar 23, 2023 - 16:30 UTC
This incident affected: IOS App, Android App, Web App, Text Messaging, Calling, Voicemail, Mac App, and Windows App.