Issue placing and receiving calls
Incident Report for OpenPhone
Resolved
Hey folks - thanks so much for your patience. This is now resolved - we're back up and running 100%. Let us know if you have any questions. We're here to help.
Posted May 08, 2020 - 18:51 UTC
Investigating
We're identified and are working on resolving the issue with receiving and making calls on OpenPhone. This is of the highest priority and the team is all hands on deck working on a resolution for you ASAP. Please stay tuned as we provide updates on this.
Posted May 08, 2020 - 18:35 UTC
This incident affected: Calling.