Issues with logging in and signing up
Incident Report for OpenPhone
Resolved
We have received confirmation from the third-party platform that the issue has been resolved. Our team is monitoring the situation closely to ensure it is fully fixed. We encourage affected users to attempt logging in again.

We apologize for the trouble caused and appreciate your continued understanding and patience.
Posted Mar 13, 2023 - 16:54 UTC
Identified
Our engineers have identified the cause of the issue and are working to implement a fix. We apologize for the inconvenience and appreciate your patience.
Posted Mar 13, 2023 - 16:34 UTC
This incident affected: IOS App, Android App, Web App, Text Messaging, Calling, Voicemail, Mac App, and Windows App.