Unable to purchase new OpenPhone numbers
Incident Report for OpenPhone
Resolved
Hey folks! Thank you so much for your patience. The ability to purchase new numbers has been fully restored. Please contact us at support@openphone.co if you keep experiencing issues with getting new numbers.
Posted Feb 02, 2023 - 15:42 UTC
Identified
Hey folks, we're having an issue with a third-party provider where we source many of our phone numbers from. This is affecting the ability of new and existing users to purchase new phone numbers. This does not affect any functionality of OpenPhone for existing users, but it will inhibit new users from signing up. We've identified the cause of this issue and should have it resolved with this third-party provider shortly. Thanks!
Posted Feb 02, 2023 - 13:43 UTC
This incident affected: IOS App, Android App, Web App, Mac App, and Windows App.