Connection issues for calls and SMS
Incident Report for OpenPhone
Resolved
This incident has been entirely resolved. Please email us at support@openphone.co if you have any issues or questions. Thanks!
Posted Mar 16, 2021 - 19:23 UTC
Monitoring
Hi folks, we're experiencing an issue with facilitating calls and text messages. The issue started at 8:30 AM PST and has been resolved at 8:50 AM PST.

We're monitoring the situation to ensure we're 100% back to normal. Please reach out to us via support@openphone.co if you have any questions. Thank you!
Posted Mar 16, 2021 - 15:54 UTC
This incident affected: Calling.