The fix has been tested and we received feedback that all systems are 100% operational. Thank you for your patience with us. You are good to go!
Posted May 15, 2023 - 19:14 UTC
Update
We are continuing to monitor for any further issues.
Posted May 15, 2023 - 19:08 UTC
Monitoring
Our team has worked on a fix and is closely monitoring the results. You should be able to make and receive calls now.
Posted May 15, 2023 - 19:06 UTC
Investigating
Our engineers are currently investigating a system-wide outage affecting the ability to make and receive calls. This is the highest priority, and the team is all hands on deck, working on a resolution for you. We apologize for the trouble caused.
Please stay tuned as we provide updates on this.
Posted May 15, 2023 - 18:44 UTC
This incident affected: IOS App, Android App, Web App, Text Messaging, Calling, Voicemail, Mac App, and Windows App.