Inability to make and receive calls
Incident Report for OpenPhone
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 16:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2023 - 15:48 UTC
Investigating
We've received reports of an issue where some users cannot make or receive calls on their OpenPhone number. We're investigating the issue now and will provide updates as soon as possible.
Posted Jul 14, 2023 - 15:23 UTC
This incident affected: IOS App, Android App, Web App, Calling, Mac App, and Windows App.