Inability to make/receive calls
Incident Report for OpenPhone
Resolved
This incident has been resolved.
Posted May 19, 2023 - 02:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2023 - 00:59 UTC
Identified
The issue has been identified, and our team is working diligently to have it resolved. We appreciate your patience as we work on the issue.
Posted May 19, 2023 - 00:02 UTC
This incident affected: IOS App, Android App, Web App, Mac App, and Windows App.