OpenPhone
Resolved·Degraded performance

This has been resolved and all systems are operational. Thank you for your patience while our team worked on this.

Fri, Aug 15, 2025, 05:09 PM
(2 days ago)
·
Affected components
Web App
Mac App
Windows App
Updates

Resolved

This has been resolved and all systems are operational. Thank you for your patience while our team worked on this.

Fri, Aug 15, 2025, 05:09 PM

Monitoring

All operations are back to normal. Our team will continue to monitor to ensure everything is working as expected.

Fri, Aug 15, 2025, 03:42 PM(1 hour earlier)

Investigating

We're currently investigating some reports of issues with OpenPhone. Our team is on it, and we'll share more information as soon as possible.

Fri, Aug 15, 2025, 02:52 PM(49 minutes earlier)