OpenPhone Desktop app
Resolved·Degraded performance

Our Windows app is now functioning without issue. Please note that you'll need to reinstall the latest version of the app, and it should work as expected. Thank you for your patience while we resolved this.

Tue, Jul 29, 2025, 08:41 PM
(1 month ago)
·
Affected components
Windows App
Updates

Resolved

Our Windows app is now functioning without issue. Please note that you'll need to reinstall the latest version of the app, and it should work as expected. Thank you for your patience while we resolved this.

Tue, Jul 29, 2025, 08:41 PM

Investigating

We're currently investigating reports of issues with the Windows desktop app affecting some customers. Our engineering team is on it, and we'll share updates as soon as we have more information. In the meantime, the Web app is fully functional and can be used as an alternative.

Tue, Jul 29, 2025, 06:21 PM(2 hours earlier)