Messages loading
Resolved·Degraded performance

The issue with message loading has now been resolved. Thank you for your patience while we worked to fix this. If you have any further questions, please don’t hesitate to contact our Support team.

Mon, Jul 28, 2025, 05:47 PM
(6 days ago)
·
Affected components
Text Messaging
Updates

Resolved

The issue with message loading has now been resolved. Thank you for your patience while we worked to fix this. If you have any further questions, please don’t hesitate to contact our Support team.

Mon, Jul 28, 2025, 05:47 PM

Investigating

We continue to investigate the cause of messages not loading, which is affecting some users. Our Engineering team is actively working to identify the root cause and restore normal service.

Mon, Jul 28, 2025, 04:27 PM(1 hour earlier)

Investigating

We've received reports of messages not loading for some users. Our team is investigating this, and we'll provide updates soon.

Mon, Jul 28, 2025, 02:04 PM(2 hours earlier)