Incoming calls and recordings
Resolved·Degraded performance

Calls should now be functioning as expected. Thank you for your patience as our team resolved this.

Tue, Jul 15, 2025, 06:26 PM
(1 day ago)
·
Affected components
Calling
Text Messaging
Updates

Resolved

Calls should now be functioning as expected. Thank you for your patience as our team resolved this.

Tue, Jul 15, 2025, 06:26 PM

Identified

Our team has been working on a fix, and call recordings are starting to recover. We'll provide an update shortly.

Tue, Jul 15, 2025, 05:42 PM(43 minutes earlier)

Investigating

Our team is investigating delays and issues with messages, calling, and call recordings. The team is actively working on a fix, and we will share an update soon.

Tue, Jul 15, 2025, 03:45 PM(1 hour earlier)

Investigating

We're currently investigating some reports of calling issues, including incoming calls showing as missed and missing call recordings. Our team is on it, and we'll share more information as soon as possible.

Tue, Jul 15, 2025, 02:13 PM(1 hour earlier)