Inbound + outbound calling are experiencing issues
Resolved·Full outage

Calling is fully operational.

Fri, Apr 11, 2025, 06:19 PM
(2 weeks ago)
·
Affected components
Calling
Updates

Resolved

Calling is fully operational.

Fri, Apr 11, 2025, 06:19 PM

Monitoring

Outbound + Inbound calling should now be working as expected.

Fri, Apr 11, 2025, 06:08 PM(10 minutes earlier)

Investigating

We are currently experiencing issues with outbound and inbound calling. This likely affects around ~50% of customers. We are working to identify a cause + will report back once identified.

Fri, Apr 11, 2025, 05:52 PM(16 minutes earlier)

Investigating

We are currently down and investigating the root cause. Will post another update shortly.

Fri, Apr 11, 2025, 05:48 PM