Failed calls and incoming text messages
Resolved
Degraded performance
Lasted for 39m

We've identified and resolved the problem. Calling and messaging is back up and running now. Thanks for your patience! If you have any questions or need help, we're at support@openphone.co

Thu, Mar 12, 2020, 11:28 PM
4 years ago
Affected components
Calling
Text Messaging
Updates

Resolved

We've identified and resolved the problem. Calling and messaging is back up and running now. Thanks for your patience! If you have any questions or need help, we're at support@openphone.co

Thu, Mar 12, 2020, 11:28 PM
39m earlier...

Investigating

We're currently monitoring a small number of failed calls and messages. There's an issue impacting incoming and outgoing calls as well as incoming text messages.

Our engineers are investigating the issue and we will post any new information here.

Thu, Mar 12, 2020, 10:49 PM