Issue placing and receiving calls
Resolved
Full outage
Lasted for 15m

Hey folks - thanks so much for your patience. This is now resolved - we're back up and running 100%. Let us know if you have any questions. We're here to help.

Fri, May 8, 2020, 06:51 PM
4 years ago
Affected components
Calling
Updates

Resolved

Hey folks - thanks so much for your patience. This is now resolved - we're back up and running 100%. Let us know if you have any questions. We're here to help.

Fri, May 8, 2020, 06:51 PM
15m earlier...

Investigating

We're identified and are working on resolving the issue with receiving and making calls on OpenPhone. This is of the highest priority and the team is all hands on deck working on a resolution for you ASAP. Please stay tuned as we provide updates on this.

Fri, May 8, 2020, 06:35 PM