Log in issue
Resolved
Lasted for 15m

We've resolved the issue now - your should be able to log in on all platforms via Google and email. Sorry for the inconvenience. Don't hesitate to send us a note to support@openphone.co if you need help.

Thu, Aug 20, 2020, 11:58 PM
3 years ago
Affected components

No components marked as affected

Updates

Resolved

We've resolved the issue now - your should be able to log in on all platforms via Google and email. Sorry for the inconvenience. Don't hesitate to send us a note to support@openphone.co if you need help.

Thu, Aug 20, 2020, 11:58 PM
15m earlier...

Identified

Hi folks, we've identified and are working on resolving an issue with logging in to OpenPhone. This is impacting both log in with Google + email. We're working on resolving this as soon as possible. Stay tuned for an update. Thanks!

Thu, Aug 20, 2020, 11:42 PM