Can't login or signup on OpenPhone
Resolved
Partial outage
Lasted for 1h

Thank you for your patience with us. This issue has been fixed. Please refresh your page and try to login again. Please reach out to our support team at support@openphone.co if you have any questions :)

Thu, Mar 18, 2021, 07:37 PM
3 years ago
Affected components
IOS App
Android App
Web App
Mac App
Updates

Resolved

Thank you for your patience with us. This issue has been fixed. Please refresh your page and try to login again. Please reach out to our support team at support@openphone.co if you have any questions :)

Thu, Mar 18, 2021, 07:37 PM
1h earlier...

Identified

We are continuing to work on a fix for this issue.

Thu, Mar 18, 2021, 06:24 PM

Identified

Hey folks, we're receiving reports about users having issues logging into any of the OpenPhone apps. We've identified the issue and are working to resolve this right now. We'll follow up with you as soon as we have an update. If you're already logged in, I'd recommend not logging out, as you may be temporarily unable to log back in.

Thu, Mar 18, 2021, 06:19 PM