Issues with making or receiving calls on all OpenPhone Apps
Resolved·Partial outage

We've identified this issue and implemented a fix. We've just tested this out and received feedback that all systems are 100% operational. Thank you for your patience with us. You should be good to go!

Thu, May 12, 2022, 07:44 PM
(3 years ago)
·
Affected components
IOS App
Android App
Web App
Mac App
Windows App
Updates

Resolved

We've identified this issue and implemented a fix. We've just tested this out and received feedback that all systems are 100% operational. Thank you for your patience with us. You should be good to go!

Thu, May 12, 2022, 07:44 PM

Investigating

Hi folks, we've received reports of an issue where some users are unable to make or receive calls on their OpenPhone number. We're investigating the issue now and should have this resolved shortly. We'll let you know as soon as we know of anything.

Thu, May 12, 2022, 07:39 PM