Inability to purchase new numbers
Resolved
Lasted for 1h

Hey folks! Thank you so much for your patience here. The ability to purchase new numbers has been fully restored. If you keep experiencing issues with getting new numbers, please contact us at support@openphone.co.

Have a nice weekend!

Fri, Dec 2, 2022, 10:30 PM
1 year ago
Affected components

No components marked as affected

Updates

Resolved

Hey folks! Thank you so much for your patience here. The ability to purchase new numbers has been fully restored. If you keep experiencing issues with getting new numbers, please contact us at support@openphone.co.

Have a nice weekend!

Fri, Dec 2, 2022, 10:30 PM
1h earlier...

Identified

Hey folks! We've become aware of an issue with a third party phone number provider that is currently preventing us from purchasing new numbers. This does not affect core calling or messaging or any functionality for existing users outside of the ability to purchase new-numbers. This may also affect sign-ups, as new sign-ups are unable to purchase new numbers. We're working with the third-party to resolve this now. Thank you for your patience!

Fri, Dec 2, 2022, 09:10 PM