Unable to purchase new OpenPhone numbers
Resolved
Degraded performance
Lasted for 1h

Hey folks! Thank you so much for your patience. The ability to purchase new numbers has been fully restored. Please contact us at support@openphone.co if you keep experiencing issues with getting new numbers.

Thu, Feb 2, 2023, 03:42 PM
1 year ago
Affected components
IOS App
Android App
Web App
Mac App
Windows App
Updates

Resolved

Hey folks! Thank you so much for your patience. The ability to purchase new numbers has been fully restored. Please contact us at support@openphone.co if you keep experiencing issues with getting new numbers.

Thu, Feb 2, 2023, 03:42 PM
1h earlier...

Identified

Hey folks, we're having an issue with a third-party provider where we source many of our phone numbers from. This is affecting the ability of new and existing users to purchase new phone numbers. This does not affect any functionality of OpenPhone for existing users, but it will inhibit new users from signing up. We've identified the cause of this issue and should have it resolved with this third-party provider shortly. Thanks!

Thu, Feb 2, 2023, 01:43 PM