Service interruption
Resolved·Partial outage

The issue has been fixed and all services are operational now. Pleaser refresh your apps or log back in to regain access and start using the service.

Thank you for your patience!

Thu, Mar 23, 2023, 04:39 PM
(2 years ago)
·
Affected components
Calling
Voicemail
Text Messaging
IOS App
Android App
Web App
Mac App
Windows App
Updates

Resolved

The issue has been fixed and all services are operational now. Pleaser refresh your apps or log back in to regain access and start using the service.

Thank you for your patience!

Thu, Mar 23, 2023, 04:39 PM

Investigating

Our engineers are currently investigating a system-wide outage affecting all our services. This is of the highest priority and the team is all hands on deck working on a resolution for you. We apologize for the trouble caused.

Please stay tuned as we provide updates on this.

Thu, Mar 23, 2023, 04:30 PM