Service interruption
Resolved
Full outage
Lasted for 3h

We have confirmed that the issue has been fully resolved. You can continue using the service as usual.

Thank you for your understanding.

Thu, Mar 23, 2023, 09:39 PM
1 year ago
Affected components
Calling
Voicemail
Text Messaging
IOS App
Android App
Web App
Mac App
Windows App
Updates

Resolved

We have confirmed that the issue has been fully resolved. You can continue using the service as usual.

Thank you for your understanding.

Thu, Mar 23, 2023, 09:39 PM
1h earlier...

Monitoring

We are continuing to monitor for any further issues.

Thu, Mar 23, 2023, 08:26 PM
51m earlier...

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Mar 23, 2023, 07:35 PM
1h earlier...

Identified

We are experiencing a service outage affecting the service, mostly outgoing calls. For some, this can show a message informing you have reached outbound call limit, asking you to verify your account.

Our engineering team is actively working to have this fixed. This is an all-hands-on-deck issue, and we should have this resolved soon.

We’ll keep you posted as we resolve this issue.

Thu, Mar 23, 2023, 06:21 PM