Inability to purchase new numbers
Resolved
Full outage
Lasted for 3h

The issue has been resolved and the ability to purchase new numbers has been restored. If you were trying to sign up for the service, you may continue with the process now.

Thank you for your continued patience!

Wed, May 3, 2023, 02:21 AM
1 year ago
Affected components
IOS App
Android App
Web App
Mac App
Windows App
Updates

Resolved

The issue has been resolved and the ability to purchase new numbers has been restored. If you were trying to sign up for the service, you may continue with the process now.

Thank you for your continued patience!

Wed, May 3, 2023, 02:21 AM
3h earlier...

Identified

The issue has been identified and a fix is being implemented.

Tue, May 2, 2023, 10:55 PM

Investigating

We are continuing to investigate this issue.

Tue, May 2, 2023, 10:51 PM

Investigating

Hey folks, we're investigating an issue with a third-party phone number provider. While this is affecting the ability of new and existing users to purchase new phone numbers, it does not affect any functionality of OpenPhone for existing users. This will also prevent new users from signing-up. We've identified the cause of this issue and should have it resolved with this third-party provider shortly. Thank you for your patience!

Tue, May 2, 2023, 10:42 PM