Inability to make and receive calls
Resolved
Full outage
Lasted for 1h

We have confirmed that all issues with making and receiving calls have been resolved. You may refresh your apps and start using the service again.

Thank you for your understanding!

Thu, May 18, 2023, 06:03 PM
1 year ago
Affected components
Calling
IOS App
Android App
Web App
Mac App
Windows App
Updates

Resolved

We have confirmed that all issues with making and receiving calls have been resolved. You may refresh your apps and start using the service again.

Thank you for your understanding!

Thu, May 18, 2023, 06:03 PM
59m earlier...

Monitoring

Our team has worked on a fix and is closely monitoring the results. The ability to make and receive calls has been restored.

Thu, May 18, 2023, 05:04 PM
26m earlier...

Identified

The issue has been identified, and our team is working diligently to have it resolved. We appreciate your patience as we work on the issue.

Thu, May 18, 2023, 04:37 PM

Investigating

We are currently experiencing issues with our calling functionality. Some users may be unable to make or receive calls. Our engineering team is investigating the issue, and we will provide updates as soon as possible.

Thu, May 18, 2023, 04:34 PM