Inability to make/receive calls
Resolved
Partial outage
Lasted for 2h

This incident has been resolved.

Fri, May 19, 2023, 02:15 AM
1 year ago
Affected components
Web App
Mac App
Windows App
Updates

Resolved

This incident has been resolved.

Fri, May 19, 2023, 02:15 AM
1h earlier...

Monitoring

A fix has been implemented and we are monitoring the results.

Fri, May 19, 2023, 12:59 AM
56m earlier...

Identified

The issue has been identified, and our team is working diligently to have it resolved. We appreciate your patience as we work on the issue.

Fri, May 19, 2023, 12:02 AM