Inability to make and receive calls
Resolved
Lasted for 1h

This incident has been resolved.

Fri, Jul 14, 2023, 04:31 PM
10 months ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Fri, Jul 14, 2023, 04:31 PM
43m earlier...

Monitoring

A fix has been implemented and we are monitoring the results.

Fri, Jul 14, 2023, 03:48 PM
25m earlier...

Investigating

We've received reports of an issue where some users cannot make or receive calls on their OpenPhone number. We're investigating the issue now and will provide updates as soon as possible.

Fri, Jul 14, 2023, 03:23 PM