Failed calls and incoming text messages
Incident Report for OpenPhone
Resolved
We've identified and resolved the problem. Calling and messaging is back up and running now. Thanks for your patience! If you have any questions or need help, we're at support@openphone.co
Posted Mar 12, 2020 - 23:28 UTC
Investigating
We're currently monitoring a small number of failed calls and messages. There's an issue impacting incoming and outgoing calls as well as incoming text messages.

Our engineers are investigating the issue and we will post any new information here.
Posted Mar 12, 2020 - 22:49 UTC
This incident affected: Text Messaging and Calling.