Log in issue
Incident Report for OpenPhone
Resolved
We've resolved the issue now - your should be able to log in on all platforms via Google and email. Sorry for the inconvenience. Don't hesitate to send us a note to support@openphone.co if you need help.
Posted Aug 20, 2020 - 23:58 UTC
Identified
Hi folks, we've identified and are working on resolving an issue with logging in to OpenPhone. This is impacting both log in with Google + email. We're working on resolving this as soon as possible. Stay tuned for an update. Thanks!
Posted Aug 20, 2020 - 23:42 UTC
This incident affected: IOS App, Android App, and Web App.