Increased Incoming Call Latency
Resolved·Degraded performance

Latency issues have been resolved.

Fri, Apr 11, 2025, 08:28 PM
(3 months ago)
·
Affected components
Calling
Updates

Resolved

Latency issues have been resolved.

Fri, Apr 11, 2025, 08:28 PM

Investigating

Investigating increases in call latency. Could affect incoming calls.

Fri, Apr 11, 2025, 05:47 PM(2 hours earlier)